Service Experience Insights: Dashboard partial outage

Resolved

The performance issues affecting the Service Experience Insights dashboard have been fully resolved. The system has remained stable and is operating normally.

We apologize for any inconvenience this incident may have caused. If you continue to experience any issues, please contact our support team.
Thank you for your patience and understanding.
Posted Oct 29, 2025 - 16:41 PDT

Monitoring

The performance issues affecting the Service Experience Insights dashboard have been resolved.

We will continue to monitor the situation closely and will provide a final update once we have confirmed sustained stability.
Posted Oct 29, 2025 - 13:40 PDT

Identified

We are currently experiencing performance issues with the Service Experience Insights dashboard. Users may notice incomplete page loads, slow response times, or missing assets.

Root Cause: This issue stems from degraded performance at our backend CDN provider, which serves static assets required for dashboard functionality.

Impact: The dashboard display is affected; however, core services remain operational. Backend API servers continue to function normally, and agent metrics collection is unaffected.

We are actively working with our CDN provider to resolve this issue and will provide updates as they become available.
Posted Oct 29, 2025 - 11:10 PDT
This incident affected: Service Experience Insights (Web Dashboard).